About the Help & Support category

Hey JoeVolcano27, our FAQ here might have some useful information on managing your subscription to the game: https://ludia.helpshift.com/a/jurassic-world-alive/?s=subscriptions
More information can also be found if you go into your in-game Player Profile > Settings menu and tapping on the VIP button.
If you’re still having issues, our support team could assist you if you emailed them here at support+forums@ludia.com with your support key.

Hey my friendly battles won’t work

Hey Keely, could you try force closing and relaunching your game and see if that helps? Also, if your friend is not online or they’re already in another battle with another player, they might not receive your battle request. If you’re still having issues, reach out to our support team here at support+forums@ludia.com with your support key, and they would be happy to help you.

I have no friends but there listed on challenges, when I chose to challenge no reply, my roommate challenges me but no option to accept.

I have Android 7 phone Alcatel. Pls help

Yes I have same issues have written over week

I love JWA a lot. But my alliance disappear !!! And I don’t know why?
P’ease help Me!

The game Kept freezing on me during the tournament! Yes you David are supposed to get 500 cash and I never did ???I thought that tournament was kind of lame with all the bugs and everything that I had to put up with

I’m sorry to hear that the game was freezing for you during the Tournament, @sean_hern. There is a loading issue that is affecting players with devices that have 1GB of RAM or less, but our team is working on addressing that.

As for the Tournament rewards, a visual bug occurred placing all players in the Top 500, however, as this is only visual, the rewards you received from the Tournament should have been correct. If you still have any concerns, do not hesitate to contact our support team here at support+forums@ludia.com with your support key.

Hey MorbiusX, could you remove the screenshot from your post? As it shows your support key. :smiley: Thanks!

If you’re having trouble getting into the game, try some of the troubleshooting steps here and see if it helps: Stuck on loaded screen of game?

Also, try changing the time zone setting on your device to either New York or Toronto and then restart your game.

Let me know if that works.

we are having trouble connecting to our service. please check your internet connection and try to log in again please help

For over the past month I have had loads of raids that I get invited into that I can’t actually join.
I get into the lobby and try to pick a dino but whenever I press the select button nothing happens. I can select a dino like normal and the preset I used last time loads normally too. the button itself goes smaller as if I had pressed it but nothing actually happens.
If I leave the lobby and rejoin it doesn’t fix. reloading the game doesn’t fix. entering the lobby and becoming host doesn’t fix.
any help?

Hi, I just got back into the game and tried to begin the campaign (when i had played a while ago this didn’t exist yet).

But the tutorial is bugged in mission 1, it asks to use the iguanodon, i click it, it enters the battlefield, and it just keeps like that, the tutorial doesn’t go forward to the next step, i can’t click in anything and have to clear app data and restart to play the game (without playing the campaign).


can anyone help me? is there a way to skip tutorial or something like that?

I absolutely love this game, I do. However, once you get your dinos to about level 10 the game doesn’t give you enough coins to upgrade. The fact that there’s. Daily limit on the coin incubators, or that ya’ll can’t just award more tokens really ruins the game. I get on a lot, but at then end of the day it blows because you have to sit and Twiddle your thumbs for weeks.


Broken

A post was split to a new topic: Alliance notification & chat issue

quando tentei aperta no botão evoluir Demorou muito para apertar aí eu consegui apertar mas aí depois a Claire ainda continua falando que era para apertar no botão evoluir tenrsão erro atualize isso por favor


MOD EDIT

Translated from Portuguese

when I tried to press the evolve button It took a long time to press then I managed to press it but then Claire still keeps saying that it was supposed to press the evolve button voltage error update this please

Unfortunately, our forums are currently only in English, we have gone ahead and translated your post using Google Translate. Please remember to include an English translation in the future.

Hello my player name is nfnqfjnq. I noticed all of my extra health attack and speed are at 0 and they should be in the 500 500 2500 range. I just don’t know what exactly I had before everything went to 0.

How does one cancel a swap? How does one cancel any move? I have not discovered this in years of trying. Please let us ALL know how one cancels a swap, at least. I’m all ears.


Uploading: 6E21E17B-1CCF-427B-9C5C-79875D8CC8EA.png…

Not sure which one was supposed to happen yesterday but NONE of the legendary Dino’s showed up to me. I went around many places and nothing happened.
Many of my friends from previous groups and people from international groups on discord said the same thing.
I’m really annoyed because I wanted two of the six legendaries that were supposed to come up.
Now I only ended with the unique ones popping.

Ps tried posting the videos to prove what I meant but they don’t let it. Just pics.

My message to Lydia’s support yesterday:
the problem is there were supposed to pop some legendary Dinos and they didn’t pop for none of the three groups I’m part of. And each notification shows different legendaries.

The weekly events show lystrosuchus, dreadactylus and paras lux, in the meantime it popped up a notification saying we should be able to find poukadei, dodocevia and eremoceros around the supply areas.
Not sure which one was supposed to happen but none of the six showed.
I’ve been out today and so we’re my friends. They were all confused that only the unique ones showed.

Hey there, sorry for the possible confusion! This advice was based on a MUCH older version of the game and should therefore be disregarded.