AMC Incubator


#1

I don’t know if anybody else is having this problem, but I felt that it is an issue that is definitely worth mentioning.

Earlier today I took a drive to the nearest AMC theatre (approximately 90 minutes away). I took this excursion simply because I wanted the rewards that the incubator included. However, I ran into a serious issue. I could not reach it from the outside, so I had to walk into the theatre. Unfortunately, my connection was lost as I entered, and I was unable to receive the rewards. I do not believe that I will have any other opportunities to collect this.

I have pictures of the theatre and a screenshot to prove I was there.
I don’t know if this is possible, and TBH, it’s not that big of a deal, but is there anyway that these can be rewarded otherwise?
I spent quite a bit of time on this, so ideally I could be rewarded, but if that isn’t a viable option, I understand completely. Who else has had this happen to them?!


#2

Did you try spinning it again? After restarting the app?


#3

Some had that issue I can say one way around it is if you have a friend or family member whom you can tether your phone’s Wi-Fi off of it or use the internet you can usually ask the manager or employee for the Wi-Fi password if it’s protected


#5

The form got me 2 times I will work around this


#6

I tried all these.
I not only restarted the app six times, but restarted my phone twice and used by brother’s phone to see if it worked on his, as he was able to get the incubator on his account. I could not connect to the WiFi either.


#7

The issue was that I never got close enough to it, and thus could not spin it. My GPS was even on high accuracy, and when I was standing right next to the front entrance it had me positioned far away for some reason.


#8

Oh I see. Maybe try signing in your account on another phone?


#9

I tried that as well.