Android 12 GPS Issues

I am exact same since the Android 12 update I commute to work on the bus daily for about an hour and all this week my arrow just stutters and doesn’t flow smoothly I contacted support but all the things they told me to try didn’t help its driving me nuts

How do you mean run in the background ?

When the GPS goes crazy in JWA, I start Google Maps and then go back to JWA. In general it fixes it.

Nothing fixes mine been like it over a month now it’s just stupid at this point

Mines the same still not working since the last update to Android 12

Bump! This is still an issue. >.<

I now have two Samsung phones updated to Android 12 and they’re both failing to get locations.

I have set Google Maps to be allowed to get my location at all times but JWA isn’t moving. I can only get it to move if I switch Google maps to the foreground, but you all know how bad this game is with switching between apps…
I have tried clearing the app cache both for JWA and Google Maps and multiple reboots.

It does detect known wifi hotspot locations, so whenever I pass by one of those it jumps. But, that is obviously terrible accuracy on its own.

2 Likes

Has anyone found a fix for this or Ludia just has to update the game and fix it itself?

I know that it works fine when you set and run a destination in maps.
This can be run in the background so it doesn’t affect the screen at all.

For once Ludia is not the issue. That’s an Android issue.

I had to turn off “precise location” to get a few apps to work properly. I noticed the issue with my today weather app. As soon as I switched it off everything worked fine. It’s not about access.

Go to settings, location and pick the app and toggle off precise.

I have had no issues with gps for a long time. Updated to latest U4 update on the s20 this morning and game is completely broken jumps all over the place have tried all the usual clears and location setting and nothing fixes it. All other gps apps work perfectly.

I got the same issue.
Played well 2 years. Today was an update of my Samsung Galaxy S10+ to an Android 12 (OneIU 4)
And GPS location becomes completly broken.
Looks like it always not exact and having only some ponts to jump in (even when moving)

Turning off your location while in game, you will get a pop up message to turn on your location. This fixes it, however there are now minor jumps instead of a smooth follow. I have now turned off the wifi related settings in location and will write back when I test this out. Basically, should work, if you choose only data or only wifi, but a mix is bad.

I found it odd to see this going on all the way back to October, as I only just a few days ago got a message to update on my S20.


I found that running google maps on top of the game was the only way to fix it, like some of you are saying. Notice the right corner.

The location of my map is way off from my physical location. So far off that I am actually in a different zone. Why is this and does anyone know how to fix it?
Already tried updating Google maps and restarting phone and game.

Thanks.

I turn on google maps to get the pulsing dot to come to my location. I did what @schtemty suggested and set my home as a destination and that worked to keep the game following me when I went for a walk. It was a bit annoying as it was dinging me for going the wrong way and giving me directions home, depending where I was and which direction I was walking.

The game does follow when you hit 30mph in the car but up until then, it just stays where you were parked.

Just sitting playing at home, I bounce around to different spots all day, up to a mile from home but generally close which isn’t a big deal because I get put close to and into a park and get some shots at park spawns.

If this keeps going, I’m hoping this will help me to reach out of range Apex raids from home and not have to put on all my winter gear to go out walking in the cold and snow to get them and bring them home. I can’t control the bouncing and just have to wait and hope to bounce where I can reach what ever the day’s raid creature is that I want.

Just wondering if anyone was heard anything concrete from Ludia about them looking into this ongoing Android issue??? You know, other than the default sorry this is happening automated reply… :triumph:

1 Like

The response I had the other day was yes we know but there is no fix on the horizon.

Did they actually e-mail that response to you?! That’s horrible :persevere: I know it’s affecting a significant chunk of players! They’re going to lose a lot of players if they don’t address this issue :pensive:

Sadly yes and yes