Android Compatibility

Does anyone know what the current compatibility requirements are for android devices? I tried googling it and the only info I found was from 3 years ago…

Hey UnionRags123, Android devices running OS 5.1 and up should be compatible.

If you have any concerns about your device compatibility, don’t hesitate to contact our team at support+forums@ludia.com.