Anveil's heal ability didn't work

My Anveil didn’t heal any dragon when I used his ability.
I nearly lost the battle because of the bug.
Since I cannot attach the photo through the in-game support, I reported the bug here.

I hope you can fix this soon.

Anveil.bug has been known for ages and before last couple updates at least. Not sure why they dont fix

You should be able to attach photos thru in game support. At least I can, i am on android

I could attach photos before the update, but now there is no icon for attaching photos.
I don’t know why, another bug maybe.

And My Anveil’s heal ability worked good before they release the update. I thought it’s a new bug for me. :thinking:

I thought they fixed this bug? (My Anveil worked fine lately even with dead team members.) But it seems like the bug is back or had never been away and I was simply lucky.
The main theory about the bug is that Anveil tries to heal one of the dead dragons because their health 0 is lowest but since Anveil can‘t revive dragons, it seems like nothing happens. Everything is fine as long as you manage to keep everybody alive.