Ludia Forums

Anyone else's game stuck at 17 loading?

My game just got stuck at 17. Cleared data, cache, uninstalled, reinstalled, reset phone, nothing is helping😡

Have you tried turning data off and on again? Same for Wifi.

Yes, nothing seems to be helping😔

It’s not you, it’s the server. When you first get this 17/26 thing, just wait an hour and you should be able to just log back in normally.

2 Likes

Thanks, I was finally able to log back in about 20 minutes ago🙂

Been stuck on 17 for the past hour. Tried uninstalling and reinstalling. Shutting down phone, resetting cellular and WiFi. Nothing seems to be working.

They say it’s the servers, it came on after about an hour and a half later for me

Has it came back on for u yet? If not clear your data and cache but make sure your connected to google games or Facebook first

Yea it came back after a few hours. Not sure why. Only difference I noticed was my collection said 99+ in smaller writing.

1 Like

I’ve had it stuck at 19/26 several times yesterday. But once I closed the app fully and restarted, it was ok.

1 Like