Ludia Forums

Battle Lags?

#1

I recently keep losing battles because I would be stuck on an attack screen and unable to do anything until I manually close the app and reopen it again. It’s annoying. I’ve been stuck at 1800 when I could have easily leveled if it weren’t for the fact that closing the app and reopening to get the battle to progress loses time and I often lose my turn to pick a move.

Is there a way this can be fixed? I’m tired of practically having to ’ throw a game ’ just because the app decides to randomly stop working mid battle. My WiFi is pretty fast and I have Verizon when it comes to data. I don’t have any issues running any other app, it’s just always the Jurassic World battle sequence that I consistently have trouble loading.

#2

Hey SunlightAura, I understand that having to reboot your game mid-battle is really frustrating and in most cases, can cost a victory of the match. Our team is always working towards improving the stability of the game, and we hope that we will see less of these issues in future updates. For now, could you try some of the troubleshooting steps on this thread here and see if it helps: Lost a battle I was winning
Let me know if there are any improvements after trying those steps.

#3

At this point, I rather be compensated somehow. I can confidentially say I’ve lost at least 200 points due to a laggy game and not being able to make vital decisions. I’ve done all the steps as recommended, and there hasn’t been any change. I still get matches where it would suddenly stop working and I would have to close out and open it again.

I’m back in the 1700s because these glitches keep happening. It’s really discouraging.

#4

I’m sorry to hear that you’re still having issues with some of your battles even after trying those steps. I know that having connection hiccups in a battle can be discouraging especially if it’s causing the loss of a game but there isn’t really much our support team can do for compensation. However, they’ll be happy to try and provide some additional troubleshooting if you contacted our team here at support+forums@ludia.com with your support key.