Battle search error

I recently came back to the game and whenever I try to find a pop match in my current arena(mt. sibo) I always get prompted to connect my google play account then it would stay loading and constantly ask for it over and over to eventually crashing. I uninstalled and reinstalled in Hope’s of fixing the issue to no avail. I really dont want to start a new account either. Is there some way to fix this issue?

Update:sent a ticket in with my support code. Awaiting a response

Hey Noah_Hurtado, I’m sorry to hear that you’re having this happen during your match searches. Could I ask you to contact our support team here at support+forums@ludia.com with your support key so our team can take a look and assist you?

Yes I can and where can I find the support key?

If you go to your in-game settings menu, it should be the 8 letter code located at the bottom left corner.

Update: I received a email with solutions to the problem and none of the solutions worked. I believe it is a current ingame bug. Disappointing none of the solutions worked but still hopeful

I have posted this issue before but I just want to make it known again. The problem is when I search for battles,I never find any battles then prompts me for my google account then eventually gives a error or crashes. I tried switching my team to my lowest dinos to balance out my team for my current arena which is mt.sibo the 2and one but to no avail. I tried all the solutions I was prompted through my 1st discussion but to no success. So PLS FIX so I may get out of my limbo

I’m sorry to hear that you’re still having this issue, Noah_Hurtado. If you had already reached out to our support team, could I ask you to follow up with them so they would be able to investigate further?

Thanks!

To lay it out,the first post I had to use these “solutions” to help solve the problem to which they did not succeed.


Then,I tried to search for a battle when I got a battle tip stating"opponents are matched based on teams and trophy count" so I placed lower dinos ranging from lvl 2-6 due to me being in arena 2 mt.sibo but to no avail either. I’m always connected to wifi which still dosent help. I even sat an hour to see if something change but nothing. So I believe it is a ingame bug