Can’t collect tournament season rewards


Whenever I tried to collect my tournament season rewards it just kept loading all time.

Do you have an attack refund token still in your inventory? I’m hearing you need to use that before you can get a new one. Something must be broken with the intended “if attack refund token exists in inventory, send extra one to mail” thing.

1 Like

Hey Albert_Rex_Ding, we’ve brought this up with our team so that they can investigate further.

Thank you!

I think something got messed up with this as I have been in my alliance for months and can’t accept the reward. It just brings up a spinning circle and I can’t do anything else but restart the game

Others discussing it online seem to have the same problem.

@Ned

Do you have an attack boost refund token still in your inventory? I’m hearing you have to use that before you can collect the new one (seems like their “if attack refund token exists in inventory, send extra one to mail” thing isn’t working).

1 Like

Yeah, but as you pointed out, I shouldn’t have to use it if what they said about an extra going to your mail is true.

1 Like

Completely agree. Just pointing out the issue so they can fix it faster. If anyone is in danger of being kicked from their alliance, they could lose championship rewards altogether if they can’t collect now.

1 Like

@Ned is this the reason? (People not using their previous token and the system not programmed to forward the additional token to the ingame mail?)

Hey Poezzzie, the issue has been forwarded to our team, and they’re currently investigating. :mag:

2 Likes

Thanks, I still haven’t used the free token yet. I’ll try that now~

Thank you, swift as ever :blush::heart:

@Ned
Going to presume this won’t be a quick fix.
We’re supposed to be able to store one in the mailbox.
This means I’m going to have to waste a token then to claim the reward, as there isn’t a dino I actually want to unboost at the moment.
Will support be willing to compensate for this?

I had this happen also. Tried to collect twice and both times got the spinning thing and had to close the game. I do have an unused token though so that must be it.

Who would have thought that having a cap of 1 would lead to issues?? :astonished:
/s

I understand the need to make sure they aren’t exploitable and all, but from the get go this whole schema was prone to issues like this. Forcing people to use a single item before they can bank another is just so dang stingy.

2 Likes

Hi,Today have tournament reward but i can’t receive. when i touch collect,game will load like in picture.
How can i do with this situation?
(Play with iphone)


I’m having the same problem.

As others have said, I was having the same issue. A month or so ago after the update I was given a boost token. I had no use to use it, so I did not use it. But it was in my inventory. I went to a random creature and used that token and then I was able to accept my tournament rewards with no issues.

1 Like

The loading circle spins, but the game stops responding. Waiting for several (10) minutes gets nowhere. Anyone else have this problem or any suggestions to fix it?

So far the only solution offered is use your existing boost reset whether you need to or not.

Any time I’m trying to collect rewards it doesn’t let me I click it and it spins infinitely being stuck on this screen and the only way I get out is if I close the app