Can't access game through Google play

I moved today, from the UK back home to the USA. Sitting in the plane in London I was battling, turned my phone off at takeoff. Landed in the US and tried to fire up the game and now it says my credentials fail and it can’t load my achievements! My secondary account loads just fine, but my main account seems lost… Tried all kinds of things but nothing has worked. Any help or advice? I have a sneaking suspicion they think I’m spoofing and may have shut me down!

Hey @D_MOL, I’m sorry to hear that this has happened! I can safely say that I’m not sure what’s happened, especially given that you’re able to access your secondary account, but our support team would be glad to investigate this on your behalf. Can you reach out to them at Also, it would be really helpful if you could include the support keys for each of your accounts! Hopefully, we can get you back to collecting DNA as soon as possible.

I wrote and included a screenshot of the error message.

1 Like

That happens to me all the time, just give the game some time(while off the app) and it’ll work eventually. Same for the game not loading.(for me at least)

Hmm. I hope is that simple. In the meantime, I’m missing out on coins, dna, and events!

1 Like

You can try changing loaction (for time) like you do for the game not loading and see if that works, it did one time when my game didn’t fix itself from what you’re having right now.

You had mentioned it happened after going from the UK to the US. It would be a long shot but maybe there was some sort of sync issue… Have you tried connecting with a VPN setting the IP to a UK location?

Maybe then it would sync and afterwards work back in the US.

But then again I’m just spitballing and have no idea.

I checked my Google play location and that is still set to UK. I’m on 3 mobile, which has a “feel at home” feature so I can use my data in the US as if I were still in the UK. If it weren’t for the fact that I can log into my second game no problems, I’d think it might be something weird like that, but that second account works just fine. shrug

Due to a weird issue with google play games my primary game won’t load - and I’m missing the gorgosaurus event!! Those of you who know me know I have a L27 - and after this event I was going to be close to, if not reach L28. (though saving the coin to actually evolve would take a few days). I’m pretty bummed.

On the other hand, I have moved back to the US, warm sunny Florida, so my hunting will not be effected by cold, rain, long nights, and general winter blahs. I’m also hoping to come across some things that were virtually (if not completely) non-existent in Edinburgh.

Hope to be back in business soon. If anyone is familiar with this error code - let me know. I have written support and they have already answered.

Remove google account and add it again.

Done - didn’t help. :confused:

Probably cleared cache too.

Check google maps if it still shows you in UK.

Good thought - just did it but it showed me in the right spot.

I have done a lot of the more apparent things that might fix it. The weird thing is my secondary game loads just fine. What is most frustrating is that I can’t even think of a reason. I was sitting on the plane waiting to take off and battling. I started an 8 hour incubator and then shut off the phone. About 9 hours later I land in the US, turn on my phone and BAM, no access. It’s just weird.

Thanks to everyone for the tips!

YAY! I signed in with facebook and everything was there!! SO RELIEVED!
Time to hop on the bike and do some searching!!


Ah, I’m so glad to hear that you were able to get back into your game… That must have been quite the relief!

Please don’t hesitate to reach out to us again in the future if you need help.

Happy hunting out there, and be careful on your bike!