Ludia Forums

Can't buy gauntlet power-ups

#1

Hi,

I am unable to get more power-ups for the gauntlet.

Also, I keep getting an error that I can’t connect to the store:

And here

I tried using BlueStacks, with or without VPN, and my android device.
I’m physically in Finland, but tried also connecting via VPN through UK.

#2

Hey Vedran_Brnjetic, could you please try some of the troubleshooting from our FAQ here on your android device: https://ludia.helpshift.com/a/dragons-rise-of-berk/?s=troubleshooting&f=why-did-my-game-close-unexpectedly&l=en
Also, we recommend downloading the game through the official app store on your devices.
If you’re still having issues after trying those steps, contact our support team here at support+forums@ludia.com with your support key and our team could take a closer look. Thanks!

1 Like
#3

Ok, thank you for the help, I got it working after reinstalling the game on BlueStacks. Apparently I got randomly logged out from the app-store on the virtual device, I re-logged in and now everything seems to be working.

Thanks for the pointer.

1 Like
#4

I’m glad to hear that everything is working correctly again, @Vedran_Brnjetic.

1 Like