Can't install game on new phone


I just bought a new phone and I can’t install the game from Google Play. It says my device isn’t compatible with this version. The phone is Huawei Mate 30 pro with all Google stuff installed. I can install other apps and games, including Pokemon GO, and everything works fine. Only JWA refuses to install. Please help.


OT: Sorry, can’t help. But your profile pic fits the topic perfectly. :smiley:

I’m sorry to hear that you can’t install the game on your device, palis. New devices that are release could experience some delays before being compatible or supported.

However, please rest assured that our team is constantly working on bringing support to devices that can run the game, as fast as possible.

I’m having the same issue also using a mate 30 pro. I did some investigation and can conclude that the root cause is because our phones are missing two files from google maps library, namely and
These are not incl in Google Maps app but are supposed to be installed by the vendor so merely reinstalling Google Maps won’t work
You will need to root your phone in order to import the files into your phone
Now i suppose the big question is why does this game require these files to install while other Geo games like Pokemon Go and wizards unite don’t?
Is there any way to get in touch with the software development team in ludia so we could let them know this and if they can release a version to bypass the need for these two files

I have solved the issue now. Go to the below and install the file as per their instructions the game should install and work

I got it to work by installing GMS. Now the game is playable for me. The only thing that still won’t work is AR. Did you get to solve this problem?

Nope the ar doesn’t work on mine either. I had to install both the file from the xda website as well as GMS to get the game working, because initially it doesn’t appear in play store and when I side load the apk file it gave an error msg while installing. But the file from xda solved everything for me

Interesting… I’m able to view the new 3d animal models in Google search which technically requires arcore working on my phone but the game ar still does not work, it just crashes when I press the ar button

here is the latest method to install GMS on Huawei

Compatible Models

Huawei P40 Lite
Huawei Mate 30 Pro
Huawei P40 Pro
Huawei Mate Xs

  • Must work on all Huawei devices without GMS

Also, Fix the Google Play services error:

Download GMS files V4

I have the same issue but I’m not comfortable downloading anything like that. If I could just get help on getting the missing files into my map so I can finally play the game that would be great.

What’s your situation atm? What is your phone model and do you have GMS installed?