Cant install


#1

Whenever i try to install it from the google play store i get errorcode 505
I’m on a galaxy s8 with android 8.0


#2

Are you sure it is already available in your country? As far as i know it isn’t yet available everywhere… Cant really think of something else… :confused:


#3

I’m not certain about that but my brother was able to install it on his s5 neo


#4

I did a quick google search & it might not be the app but just your google play. Check out the link and see if any of the solutions work out. :slight_smile:

https://drfone.wondershare.com/android-issue/error-505.html

Or via the official google support forum.

https://support.google.com/googleplay/forum/AAAA8CVOtD8hxP7caxjR8I?hl=en-IN

Hopefully one of both has a working solution for you!


#5

Sadly those didnt work, i already tried googling it and havent found a solution yet. Thats why i came to this forum. Im starting to think it might be the android version or galaxy s8 since most of the reports i seen for this error with this game had an s8 with android 8


#6

It is not just the S8. My son has a Nexus 5X running Android 8.1 and we get the same error. My daughter has the same phone and OS and she could install it. Clearing the cache did not work. I think it is a conflict with something else installed on the phone, but I don’t know how to troubleshoot. I don’t want to reset the phonse if not necessary. Any other suggestions? Thanks.


#7

We figured it out. It was a conflict with permissions in a different app. In our case it was Dead Shot 2. After we uninstalled it we could install Jurassic World Alive.


#8

Thank you, i deleted like 20 apps and now mine installed too :grin: