Can't load game stuck 22/31

Hello Davy, my game also happens the same, can not open, progress freezes at 17/31
Please help

This whole glitch or whatever is going on here is just one more reason for me to quit the game. Everyone else like Supercell NEVER glitch out or rarely. All I can say is that I hope this gets fixed soon

I can’t load the game at all since the update. Sits at 16/31 and freezes.

Hi @PlayerNo1, If you haven’t already please write to support+alive@ludia.com so we can gather more info on the issue. Please provide your support key as well.

Thank you!

Do you think removing the update would work

You can fix the update and then import it into the game when the Bug has been fixed

I deleted the game and re-installed it, and it worked

This happened to me at the start of 2.16

I have tried everything and it still doesn’t work. If this doesn’t get fixed within the next few days I am quitting the game until Ludia can get their games together and start being like other game creators in making QUALITY GAMES. Ludia has the right idea but now they need to make it work in a manner that workes and does not glitch out players every update and at random times.


Mine now starts to open up and freezes every time. Happening for the last 8 hours

Same with me