Ludia Forums

Can't start incubator

Bug Description:
Clicking “Activate” on my 8 hour incubator, does not activate the incubator

Area is was found in:

How do you reproduce the bug:
Step 1- Click on Activate on an incubator
Step 2 - observe
(add more if needed)

How often does it happen:
Right now, every single time

What type of device are you using:
Android 10 OS, Nokia

Anything else? (add screenshots or additional information here)

Hey Juraysic, could you try restarting your game and see if you’re able to activate your Incubator?

Yeah, I tried that multiple times.

That is strange :thinking:. Could you try collecting from one of the Incubators you have ready and then try activating the 8-hour one again and see if that works?

1 Like

I was avoiding that to have 4 for a kickstart tomorrow, but know that I did it, and then restarted, the 8 hour one started.
Thanks, Ned!

1 Like

I’m glad to hear that it’s working again! :smiley:

If you watch an ad to speed an incubator, that incubator needs to be opened before starting a new one. Not sure if this is intended or a bug, but it’s the way it is.

2 Likes

I did not know that, will keep it in mind. Thanks!

That’s a bug of course.

This is the bug I run into constantly. If I watch an ad that doesn’t end the timer, and then the timer ends naturally, I can’t start a new inc until I open the first one. @Ned

Hey @Ned, this is still occurring! I used a few of the ads to speed along this Epic incubator and nothing I did (restarting included) allowed me to start another incubator until after opening the 24hr one… I really would have like to have saved doing so until the daily goals had reset.