Ludia Forums

Connection to server lost or timed out

Hi Team and @Ned

Whenever I am trying to launch the game, Jurassic World the game, it gives error that connection to server is lost or timed out.

I have tried everything from restarting my phone, uninstalling the game and reinstalling it, forgetting the network and connecting again. Strange thing is it finds the Internet connection to download the 1 gb of additional game data but when it is complete and I try to play the game it seems to lose Internet connection or get time out error.

I have on an average 2gb of ram available at any point on my android phone with 4 gb. So it is not an issue with my phone or Internet.

I am having this issue since Friday night and I am not going to be able to win the gorgosuchus tournament :frowning:

Please have a look at the this issue. I have even dropped an email to support team.

Thanks and regards,

1 Like

Hey Mohit, could you please make sure that you have enough internal storage on your device to run the game as well? If you’re still having issues, our support team would be happy to take a closer look into this once they get a chance to see your ticket. There are also some additional troubleshooting from our FAQ here that could help as well:

I am able to connect to the game but am having constant issues on my Android phone as well when doing battles, it would keep tossing me out in the middle with the same message. Sent my info to Ludia support a few days ago, but never heard back again (other support questions likewise ignored, they don’t seem to bother much with them, other than sending out links to FAQs). Have fast and strong wifi, brand new Samsung S10+ with plenty of storage free on it. Also about 2 gig RAM free most of the time, I would try clearing all background programs and get it up close to 3 gig, but still had issues. I’ve switched over to using my iPad Pro when there are events I want to participate in, and have had almost no problems at all on it.

1 Like

Having the same exact problems I don’t know why, my phone has at least 32 gb of RAM and it’s a Android

I have tried the same thing but it still will not work Ludia is acting up and needs to fix it’s bugs instantly.

It keeps happening to me every 2 or so minutes it drives me mad when I’m doing battles to but people have said that it will be fixed when update 36 comes out

I am also having the same error message for Android app play. It’s been happening for a while now-any solutions? Ive tried all the above? Thanks

1 Like