Ludia Forums

Customer Support Glitched Out

I have a case with customer support since I can’t change two characters in my alliance name: NorthernRapters to Northern Raptors. Someone told me they would get a team to check it out and I had a notification in the mail tell me that they had finally reply after several days. I went on to check and it shows my old case conversation instead. I tried to type and it says failed to send automatically even if I try to resend. I restarted the game and it failed.

This is a little aggravating when I have two accounts (mine and my boyfriends) who are also missing the valentines incubator and I can’t start a new case all because I can’t change the name of my own alliance. I have an S9 and I tried to access the support through the mail button and the settings button.

My new case is above the old case but I can’t reply to it or end it so I could start the new one about the valentines incubators.

Hey StinkyPanda, could you send me a private message of your support key? Thanks!