Ludia Forums

Device not compatible with version


#1

I have a meanit c4 (android 7) and i am not able to play, please help.


#2

You need to download the Google Labs ARCore software from Google play store first. It doesn’t come pre-installed on your device, but it is a free download.