Ludia Forums

Dig Deep Achievement

For some reason when I use Dig In with my Mammolania it is not counted towards this achievement. Do you need to use a specific dino or am I experiencing an error and need to contact support? Just wondering if anyone has encountered the same problem. Thanks.

Lania is having Dig In Taunt, not the “regular” Dig In.
Try to use one of the deers (Epic, Rare) in a campaign mission.

4 Likes

It has to be just “Dig In”, not any other variety for it.

Same for Pounce.

2 Likes

It doesn’t work because it’s dig in taunt
Not the normalmdig in ability

2 Likes

Thank you all. Figured I was doing something wrong lol.

High pounce worked though.

I don’t think just pounce is in the game anymore and has been replaced by high pounce. I couldn’t find anything still with it.

1 Like

For the Pounce achievement I used my Spyx and that’s Precise Pounce, not just simply Pounce. So it seems like some achievements are more specific than others.

2 Likes

Really? It didnt for me…

Edit:
Wait, I’m thinking of a different one.

2 Likes

I’m pretty sure pounce got renamed to high pounce in 2.0, so that’s why it works. Precise pounce works too, since I got the achievement from using my spyx.

I tried using high punce and it worked

Same here. Used Smilo and worked. Used Turtle and it failed for the achievement.