Ludia Forums

DNA Request Gone Without Collecting It

#1

So just a short while ago tonight when the DNA request timer refreshed off cooldown, I put in a new one for Irritator G2. I look a half hour later it says ready to collect on the Alliance icon in the bottom right.

I go in and my request isn’t even on the list! Not even hidden as far up as I can scroll. I already restarted the game to see if that would resolve it and no, it didn’t. I still am subject to the several hour wait for the following request attempt with NOTHING to show for it.

#2

Same happened to me tonight. Except I never got the collect notification. My request was just gone. I already emailed support about it.

1 Like
#3

What! This is unacceptable.

@Piere87… try this:
Close the game … turn on airplane mode/restart your phone and then open the game up again

#4

Nope. Still not there. I’m afraid is gone.

#5

did you restart your phone?

#6

The whole chat is broke. I don’t even see half of the requests, and wasn’t able to even send a message for an hour.

#7

Happened to me too…lost my kapro.

#8

Woke up this morning to find it’s magically back…I fell asleep before the next request cooldown so perhaps when it reset again that’s what fixed it…? Seems rather unintuitive.

1 Like
#9

Many Many times. It actually popped back up right after I made my second request so I was able to collect both of them. My first wasn’t filled though because no one could see it.

#10

Did you check this morning? Mine ended up showing up last night.

2 Likes