Download new Version of Jurassic World Alive?


#1

I just opened my game and now I am prompted to download a new version of the app.
Anything new planned after 1.3 release (I already downloaded the 1.3 version few days back)?


#2

Went from 1.3.11 to 1.3.15


#3

Update is 150 mb it seems


#4

53Mb for Android. Notes doesn’t say what new they have added but just repeats the old 1.3 stuff.


#5

For some reason mine had 150mb, really odd (I am on Android too)


#6

Is anybody’s saying you need to update, but I already did? I restarted my phone, the app, everything. Is there a fix for this?


#7

Mine works fine post downloading the update from Android Store.


#8

You need to do a manual update, from the appstore or google play (depending on your device), it will not trigger automatically


#9

I had 150mb followed by 76. No idea since everything looks the same…


#10

Well it hasn’t fixed the blank map issue still so no idea. Most likely bug fixes.


#11

Yeah, I’ve checked the App Store and there is no button for “update”, it omg says “open”. I don’t understand how I can update this without having an option to.


#12

when it did that to me a while back, I restarted my phone and it seemed to allow me to function again.

I did just get forced to update just as I was about to leave my wifi and go out in the world… so I stayed close to wifi… and hoped the Epic that spawned would still be there after the update… and it was.


#13

My app keeps on getting glitchy post update, and restarting itself :crazy_face:


#14

This is the second time I restarted my phone, and it still says to update even though there is no option to update. I think I might let it sit for a while. It worked for another game I had that did his once, so maybe it will work for this.


#15

still error code: 10058

just change from 18/22 to 10058…

i paid a lot for incubators and vip, so what? receiving tons of useless genes and bugs…


#16

Mine updated today without an issue (android).
The other day though I would get an installation error every time after downloading the 200mb, did it 3 times and I was on mobile data… after that I uninstalled, installed from scratch and it worked. Hope that helps others!