Ludia Forums

Eryops STE Tourney Oct 2019

Me too lol. I would like to check everything before my break ends though so I hope it fixes soon.

Mine too prizes are there but when you click okay the game crashes!

Welcome to our forum, although it is a sad occasion for a first post.


Mine, too. I got the prize and CRASH!

If we get a reply from @Ned now that we all should open a ticket I jump out of my window…don’t worry it’s in the first floor.

1 Like

Confirming constant crash when collecting dominator prize as well. Crashed when I went to open the pack and subsequent crash upon restarting. Both on iPhone and iPad

I got pictures of my prizes before it crashed. I hope this is still my reward. Long-time players may remember the infamous Glitch with last year’s Eyrops tournament that shut the game down for several days. Coincidence?

Also end of tournament data for @Sionsith at two different times


Hey everyone, I’ve notified our team about this.


Crashed too. Was opening pack and saw the eyrops coming at me on my android lev 80 account but then it died My lev 53 account is still working fine on my old ipad. It was only in Hunter league though. Pack opened fine. Not sure if this info helps you @Ned

Glad it’s not just me but I figured it was a bug with the prize when reinstalling my game on my phone didn’t fix the problem there… and then tried my iPad and that was crashing as well. Nice job Ludia. Why do they seem to have so many bugs with tournament prizes??

Someone mentioned in an earlier post that taking a screenshot in a match now causes the battle to throw you out… I’ve had that issue for a while now too but just figured it was an issue with my device… but sounds like perhaps it’s another game bug. Anyone else having that issue too?

I did have to skip a fair number of PvE’s to get this one done as much else as I had going on this weekend but really paid attention to what’s on the schedule and made sure I had enough points racked up to do the ones yesterday for the Golden Packs without having to play any more in the tournament. Although was really upset at losing one of the rounds of the Dino charge, first time I’ve lost one of those in awhile, and was so frustrating, as it was on the very last dino and I SHOULD have easily won, but the AI suddenly switched up and didn’t use any points on the block, as I was expecting, and suddenly had 7 points, just enough to take me out. As long as it takes to play these, I was LIVID! And of course, the next two rounds I won with dinos to spare.


Mine died a bit later when all those JW points were ticking in.

1 Like

I thought I was the only one with that problem.
First I thought i didn’t have the latest update so I went to Playstore to check for upgrades, then I tried to restart my phone, that’s why I came here to report this problem but it came to be that there was more people having the same issue
Please Ludia respond

Thanks in advance

Hey everyone, our team is aware of this issue, and they’re working on a solution at the moment.


I’m in the same boat with y’all my game crashed when I tried to collect the dominator league prize it sounds like ludia is working on a fix

i do hope when we get back in it keeps the rewards we got from opening the pack, would hate to lose the 1000 bucks i got to them re-rolling to dna T_T

1 Like

I, too, found Dino Charge more difficult than usual, especially my round 2 which was loaded with pterosaurs and me without an herbivore

Hi everyone,
We are aware of the issue and just posted [News] Jurassic World: The Game | 10/21 Eryops Tournament Issue

1 Like

the crashing was fixed but is now just happening again all the time

Same issue. Note 9, everything up to date. Tried to collect Eyrops Dominator Prize - kicked me out, unable to get back in.

Final data for the tournament: