Game doesn't load

Hello,

I installed the game on a Google Pixel 3 and on a Samsung Galaxy S8.
But the game doesn’t load on either of them. On both phones it goes until about 80% on the ‘Loading…’ screen and then just keeps ‘Reconnecting’ forever.
I tried both metered and several Wi-Fi connections which all work fine with other apps.
I can’t do anything except to exit the game. :frowning: Deleting the cache and even reinstalling the game did not help.

Any ideas how to make the game work?
Ty.

Hide the picture your support key is visible.

Oh, thanks. I completely forgot about that.

Nevermind, also, I sometimes can’t access to the game too, but I just wait a few minutes then I can get in again.

I keep trying every couple hours for 2 days now, but no luck.

Hey Mindclaw, could you try some of the troubleshooting from our FAQ here and see if it helps you get past the loading screen:

If you’re still having issues after trying those steps, do not hesitate to email our team here at support+forums@ludia.com.

The game started to work today, on first attempt, without me doing anything in particular. Weird…

I’ve already tried yesterday all the steps suggested in the link but none helped.

Anyway, I’m happy it works now. :slight_smile:

Cheers,
MC

1 Like