Ludia Forums

Game Has Become Unplayable

#1

Is anyone else experiencing weird problems today?

First there was the French in the strike tower. My game has been disconnecting at least once per battle, and sometimes up to three times (on a very strong WiFi connection). Have lost at least 6 matches this morning due to disconnects. Hard to even upgrade dinos without a disconnect. Speed indicator is worse today than ever. Game is locking up on supply towers as well.

Have restarted game numerous times, rebooted phone. Nothing seems to work to stabilize the game. Have not tried reinstalling. Let me know if that has worked for others.

Have had some of these issue in the past, but it is constant today and seems like it might be a systems issue. Have not seen a post from Ludia about server issues so wondering if others are experiencing similar issues.

Thankfully I got my 12 battles in, as painful as they were, for the daily missions, and managed to take out 10 dinos for my battle incubator so I can stop playing today.

#2

This… all day long. Even with a rock-solid 100mbps internet connection.

#3

Strike tower in French was a zludia issue, but the rest may be your internet location. I have no no problems in Eastern US.

#4

Thanks @Kwaack. Internet connection is awesome on everything else honestly, ran some speed tests. Could be a router somewhere between Ludia and my location though.