Game is down AGAIN

The game is down again Ludia! I can’t get in, and I have 5g data. I even tested other apps (discord, youtube, etc) they worked, not jwa though

Hey PyraandMythra, could I ask you to email our support team here at support+forums@ludia.com so our team can investigate this further?

Thanks!

@Ned I’m also unable to login the game as well…. Along with lots of other players.
Can the team look into this please? Hopefully we don’t have to wait weeks for this to be resolved :grimacing:

Thanks for notifying me, Gren! I will bring this up with our team. In the meantime, could I ask you to email our support team at support+forums@ludia.com so our team can gather more information on this issue?

Same. I couldn’t get in, so I uninstalled. Now I can’t download again.
.
.
Edit: I’m good to go now :+1:t2:

It works now it seems.

It’s an iOS issue, Game Center is down as many of Apple’s other services (App Store etc.)

It is now working again

Seems yesterday’s issue is back now.

I can’t get in either

One android phone can get in but the other can’t. what the crap ludia?

Same I can´t play, I restarted the phone, uninstall and install the game and it never reaches more than 1% in the loading screen (saying Server issues)

few people in the alliance had and are having this issue not me knock on wood