Ludia Forums

Game will not update

Hello there.
I am getting this error “The current version is too old and requires you to update to the latest version”
When I go to the app store its says I have the latest version already. I can not get into the game at all.
This is version 1.52.14 that I am referring to. Please could you help. Is there a way of backing the game up safely so I can delete and reinstall. Thank you in advance.

I’m sorry to hear that you are having trouble updating the game, Chuck_Novice. May I ask if you are trying to update Jurassic World Alive? As the current version of the game is on 2.7.24.

If you haven’t already, please try freeing up some extra storage space on your device.

If you are connected to facebook or google play you can delete it and then reinstall it logging in to your account

Yea your pretty behind :sweat_smile: