Ludia Forums

Glitches in the game

This is where you can post topics related to glitches so you don’t have to create so many threads.
Here’s a glitch I found really strange :


Look at the first point. I didn’t take photo of it but a Revenue Tower completed that point instead of a Horizon Observatory

3 Likes

i consider that more of a feature. I use revenue towers to finish any build mission

2 Likes

Wait really ? Well this thread started with an off - topic post then :joy:
This thread is for the glitches you encounter during gameplay basically

2 Likes

Put this in Help and Support Category so that if a glitch needs attention, it can be seen by the team

1 Like


This IMHO. Should count as one.

3 Likes

Yep, sometimes in other leagues I get this kind of battles ( although its rare for me )
Still its frustrating

2 Likes

Wait revenue towers are also used to finish builds?

2 Likes

Ik right never heard if it before

1 Like

How exactly do you do that?

2 Likes

Just click the XP of a Revenue Tower I guess ? That’s in my case

1 Like

I asked him cause he said that he uses revenue tower to finish any build missions . Yours seems like you finished a revenue tower and it counted for whatever mission was ongoing. That’s a one off thing , and as you can’t buy revenue towers as you please to do this for any build mission . So his statement made me curious as to how he does it.

2 Likes

Maybe he did the “put in market tactic and put it back”

1 Like

Doesn’t work

2 Likes

Hmm, that’s strange then
How did you do it @ankylodocus_fanboy ?

1 Like

umm… this is more of a glitch on my end. If im in a place with terrible connection (and using my old phone), when i try to collect xp from the completed tower, the game crashes. When I come back, the mission is done, but nothing gets built… obviously this isnt practical, but if i could find some place with consistently stable yet awful wifi, maybe i could beat infinite build missions…

just a thought lol :slight_smile:

2 Likes


Even with the speed up arrow its 1 attack animation is still not sped up, @Ned could you look into this ?

Also 1 battle in the tournament the opponent had suddenly lost 1 turn as well

1 Like

Thank you for bringing this up to us, SmilodonTroodon! Could I ask you to email our support team at support+forums@ludia.com with your support key as well, if you haven’t already? It would really help our team out with their tracking.

2 Likes

Will try , thanks @Ned !
Not too sure if it a global issue but I think all snakes have the same issue

2 Likes

Before I email support can I get confirmation from anyone in this forum that all snakes have this same issue for their 1- 2 attack animation ? It would really help if you could as I can include this information in my email to support maybe this weekend as the boss has finished

1 Like

Another reminder for confirmation whether all snakes have this " 1 attack not sped up" same issue
It is an issue in mine, can someone try Titanoboa or Gigatophis ? Thanks

1 Like