Gps issue and teleporting

I’ve tried my account on different devices, tried reloading game, emailed support and recieved 0 response in a week in both in game and the email address they post all over this site. Ive made sure my location acc is turned up. Ive tried turning on and off airplane mode. Nothing is getting the gps to accurately portray my location. Any suggestions?

I’m having the same problem and I was told by a member of ludia staff that the issue is my GPS even though I’ve done everything, my phone isn’t on airplane, the game has access to my location and whatnot, my location is on highest accuracy or whatever and I’m a mile away from where I should be, any other location app is accurate and pinpoint precision but it’s my fault apparently that this game doesn’t show my true location, its my fault that it won’t follow me as I walk either and I’ll jump from 20 metres away from a dinosaur to the middle of nowhere where there isn’t anything and I don’t know where its put me, I’ve told them it’s a major issue but they keep ignoring me about it

1 Like

There is GPS fixers in the store to recalibrate your GPS automatically. Try one.

1 Like

I’ve also used another phone and I’m having the same issues on that as well so it’s not my phones GPS that needs repairing but thanks anyway.

I tried 3 different gps fix apps, they allow me to relocate myself, but the gps still doesnt follow me. And im still teleporting

What phone do you have

I have the Samsung s8+

The update made it worse. Im done with the game. Great concept but when the support takes over a week with still no response

Same issue here. Not the first time it happened to me but before 1.8 I just had to Uninstall and install it back to fix it. But now nothing works. I m stuck with a teleporting map