Ludia Forums

GPS issues regarding Huawei devices


#1

Ludia, I finally signed up to your official forums to file this complaint.
Since around update 1.5, the GPS when playing JWA on my Huawei P20 does no longer work.
Many other Huawei users have this issue.

GPS works fine with all other applications and updates when I open/Close the game, but when moving around with the game open and screen on, the player icon does not move.

The only current workaraound is choosing a Google Maps route and starting navigation, that will make JWA’s GPS work fine again.

It’s annyoing and almost doubles battery consumption so I really hope there is a way to fix this.

Using Huawei P20 on EMUI 9.0.0 If that’s of any help.

I’d appreciate some feedback regarding this, it’s making the game kind of frustrating.


#2

I’m sorry that you’re having some GPS problems in the game @spadePerfect. There are some troubleshooting steps for GPS issues on our FAQ here that could help you: https://ludia.helpshift.com/a/jurassic-world-alive/?s=troubleshooting

If you’re still having issues after trying those steps, please feel free to contact our support team here at support+forums@ludia.com so they can investigate.


#3

I have a Huawei Y7 and that problem doesn’t happen to me LOL


#4

I have Huawei P9, and I don’t have this problem either.

That being said, there have been times when the player icon won’t move for a while. But it usually sorts itself out after a couple of minutes.


#5

image


#6

I have the EXACT same problem on my P20 Pro. The only way i can play JWA is turning on Pokemongo and connecting to my Pokemongo + (im using the Gotcha one) and then i start moving around again. I have come to live with that allways having that Gottcha bracelet with me in my pocket and if i stop moving in JWA i know Pokemongo have disconnected from the bracelet. Would LOVE to play JWA without that.
Thank you in advance!
PS seems like its only a problem with the Huawei P20 series


#7

Very rarely, like once per 100 times i open the game, this happens to me too, and I’m using an iPhone 7, so I assume its just a regular bug or glitch that for some reason more greatly affects HuaWei devices?


#8

Probably. This problem happens to me sometimes (GPS stuck in one point) but usually I just force reload the game (hitting home and come back to the game) and it works. Very rarely I’m stuck in a park zone somewhere where I can see event drops and spawns but not a place around here. This is the worst-case because I have to restart my phone when it happens.
All of these are probably related to how they handle the communication with the GPS from the os.

My gf has worst luck as she has a P20 pro. She just can’t play with high accuracy turned on and she has to lower the GPS accuracy to make it works. But if course this doesn’t work great on pogo. It’s like this since the beginning of the game and she tried to reach the support… Nothing changed.


#9

It happens to me every time I turn off my phone. The only solution I have is to reinstall the game. Since then, I do not turn off my phone and everything works fine.


#10

Happened to my P20 Lite. it seems to trigger on one specific location. Right now I do not open the game on that area anymore. But when happened back then I do an uninstall/install. Works again and haven’t bugged down since.


#11

Hi folks. Huawei p20 GPS issue. If you go to the location settings and scroll all the way down. Look for the Google Location Accuracy setting. Toggle it off and you should do better. Don’t know why and I found it by accident after the problem first occurred. This setting turns back on after some updates so keep an eye on it. Hope this helps.


#12

I still have a constant issue of the game follows me but it isn’t too long that something with the game hangs up and it quits following. Everything else in the game works but the game stops checking my GPS position so the map quits updating where I am. I get some ‘hung process’ thing going on. Some times it will jump up to where I am but then just hangs up at that point. It’s infuriating especially when I’m coming up to get close to a dino I want and it quits following me so I have to completely kill and reload the game which takes longer than rebooting my phone.


#13

That worked on my Huawei Mate 20.