Ludia Forums

GPS Map Location Hung-up Process


#1

The absolute biggest game ruining experience for me is the constant, I mean constant hang-ups with where the map stops following me.

The game is still working in all the other ways but the GPS is hung up and is no longer updating and showing my actual location. The picture is an example.

Yesterday, I road my bike around the area for over 13 miles and must have had to stop and reload the game well over 30 times in the 3 hours I was out just for map hang-up let alone the disconnect errors. GPS hang-ups are probably 5 times more frequent than disconnects.

This is not a poor signal issue. It’s a hung process. The next picture shows my entire rout mapped out by the MapMyFitness app where I am keeping track of the distance I ride and walk. When the JWA map is hung up. I’ll bring up the MapMyFitness app and it shows, “without fail” exactly where I am. I go back to JWA and, nope, it still shows me stuck a few hundred meters back. It’s not poor signal. JWA is still working. I can still grab dino’s back where it shows me, dart them, go back to the world and still has me hung up a few hundred meters back. I have to kill and reload this game constantly… I mean constantly. It completely takes the enjoyment out of the game.

The best thing the programmers could do is to be able to detect the hung up process and have it restart. The other thing is they could put a refresh your location button icon on the corner of the screen that would recheck and refresh a person GPS location so we don’t have to completely kill and reload this game constantly.


GPS freezes, game hangs, inresponsive
Gps does not load maps
Current location not where it shows on map
Issues localizing where i am using gps
Gps never works right
GPS tracking
GPS has been going wild
#2

I had this recently too while giving someone driving directions. I think it’s the switching between GPS-using apps. It’s like when you switch the other app takes over and when you switch back JWA cant take control. I didnt find a fix for it other than completely restarting like you said :frowning:


#3

When the GPS gets my position wrong I just force a GPS update by selecting my recent apps tab and reselecting JWA. It corrects the error without fail and it means I don’t need to kill and reload the game.


#4

Hi Valar,

I’ve tried the recent apps little square but it only refreshed my connection to JWA but doesn’t force a recheck on location. The game is still loaded when I do this, if it’s a hung process, it won’t or can’t check to update my location. So the only way to fix this particular hung process is to kill and reload.

On the occasions it sticks and then pops to my current location giving the [I am a passenger] screen for going too fast. I can’t figure what hung up or got it to break free. Occasionally it will break free after darting a dino when the screen has to completely redraw but then occasionally right after standing and darting dino’s the opposite happens and after going back to the map the GPS sticks right there and doesn’t follow when I start moving again. Everything else in the game is working correctly except the rechecking and positioning me on the map. It may be requesting a position check but when nothing comes back so it just assumes I haven’t moved because the new x, y, location isn’t getting through.

When your moving, it is doing a lot of things all at ounce or really fast. It does this every so many seconds.
Checks your GPS position
Calculates the distance for time and your speed.
Moves map to your position
Displays the [I am a passenger] button if necessary
Checks for new drops in visible range
Displays new drops
Remove drops out of range.
Checks for new distant dinos visible.
Displays new dinos
Remove Dinos out of range
Check for close dinos in close range (within 25 meters)
Display new dinos in close range
Remove close dinos out of range (more than 50 meters)

When your driving really fast, talking like a good 60mph you’ll notice everything is not loading and displaying because your phone doesn’t have the time to display everything before this continuous loop is telling it to start the whole process over. There are too many new things to display and/or turn off. If not everything displays, you wouldn’t know unless you know a drop is suppose to be in a certain spot but as you drive by, it’s not there.

In the case of the GPS check process that tells the map to move to a new coordinate, we all notice. If that process hangs, the map shows no movement, there is nothing new to display or turn off.

I call this a hung process because the coordinates are not getting though to update the map to your new location and contents that need to display.

I need to have the JWA programmers to know this is happening so they can figure out what is stopping the GPS x, y location from getting through.


#5

I don’t see the MapMyFitness app hogging the GPS. These programs just request coordinates from the phones GPS. I get these hang-ups when driving even more with nothing running but JWA.

Recently now, the GPS is hanging up while just doing my 2 mile walk at lunch time at work. Going only 2-3 mph should not be causing a hang up. It didn’t use to but it is starting to now.


#6

I entirely empathize with this topic.

Other AR games I play very consistently track my current location, using the same Google Maps services that JWA does. Then we have JWA, which is a constant struggle to have it accurately reflect my position in the real world.

This is especially frustrating when I’m out on walks with my fiancé. We’ll both be in the exact same position, but due to the horrendous status of the game’s GPS tracking, we can show up on average about a quarter-mile apart from each other. In specific locations, that can drastically increase to game’s mistaken idea that we are literally miles away from where we actually are (there’s a specific park nearby that the game’s GPS literally does not let us enjoy fully because you have to be standing in one specific location, or it doesn’t even show us in the park).

It’s extremely frustrating, considering we can be standing next to each other, and a hidden dino will pop up for one, but after 5-10 minutes of standing still or moving in a 50ft radius around us the other will never have the GPS put them in the precise position the other was in to have the hidden dino pop up.

Which literally happened last night twice in a 30 minute walk.

It’s really bad when I can be standing in one place, with full reception, nothing but clear skies around me, and in about 10 minutes of being stationary, move between 3-10 times by anywhere from 5-50 meters.

I personally feel it’s unacceptable levels of performance, considering that there are dinosaurs that will only appear if you are basically standing on top of them. Even more so when some events are location based, but because the GPS wanders or doesn’t update to where your phone physically is, and you can’t hit them for 5+ minutes as you struggle to find the precise sweet spot to actually have yourself show where you should be.

In conclusion, I feel that if the GPS issue cannot be resolved, hidden dinosaurs need to have a sort of radar ping in time with the central ring’s pulses to let you know that something is there, but you have to reach that spot to find it. Though ultimately, the GPS system needs to be fixed.


#7

I’ve been playing couple months. I used to play Pokemon go but have became real annoyed with their community where I live so started playing regularly Jurassic world alive. I love this game I think it’s way better than Pokemon go except in one area the GPS drifting and being inaccurate is really starting to get annoying. I can never tell where I’m at on the map or which way I need to go to go find the dino that I need or want. I want to continue playing but if not fixed it will be hard to continue. The new feature that you’re adding could be a lot of fun but it ruins all the new stuff if you don’t fix the old stuff first in my opinion.


#8

Hey Ryan_Fealler, depending on where you are, it’s possible that you’re in an area with a bad GPS signal. Turning your location settings off and back on again and making sure it’s set to the highest accuracy might help with this. If you’re still having issues, take a look at our FAQ here: https://ludia.helpshift.com/a/jurassic-world-alive/?s=troubleshooting
Our support team would also be happy to assist you if you contacted them here at support+forums@ludia.com with your support key.


#9

My GPS works fine on Google Maps shows my exact location shows my exact location on Pokemon go. the second strike event that I walk to and was unable to compete because yet again my GPS is off by 10 to 15 feet on Jurassic Park alive. The red circle is where my actual location anand the second one i was standing on the treasure box.Capture%20_2018-08-19-17-39-35|301x500


#10

Yet another example I have GPS for some reason acts up around the strike events and the treasure chests stopped working so I can’t get it if I walk past it! My location is where the red circle isCapture%20_2018-08-22-11-01-58|301x500


#11

Wonderful game but… with the latest update the game freezes soo many times in different situations. Yesterday:

1 freeze spinning stop. The gam got hung inte inital rotating sceen. Had to reboot.

GPS lock. The GPS stops and won’t follw 2 times.

Game reconnecting and failing, 2 times.

Nothing showing up when others have dinos on screen and I’m walking around not finding anything. Reboot of game and it shows up. 3 times

Opening chests somtimes a pain. Tapping all over the chest - won’t open. Out back in again - same thing. 3:rd time it works.

Battelling, the game does not respond to tappings on the screen. Goes into auto- mode, to 20 sec later be back in normal operation. The temporarilly freezez, to be back again. Loosing battles.

Other days, about the same, so many reboots, and batteling, the game goes into auto- move allthough I get to choose move. I see e.g. Inst cripple being choosen - I get strike.

I wish I had pics or films but I haven’t.
The game is greate but, sorry to say, extremely buggy.


#12

I’ve had the gps lock and treasure tap thing numerous time since the treasure hunts started.


#13

Since the update the game hangs all the time causing me to lose battles. I lost 4 in a row that I was winning due to it hanging in the arena. Between that and the shocking matchmaking, I can’t progress beyond the Badlands. Too frustrating to play at the moment.


#14

Actually, I’ve noticed it has helped. Before the update there were many issues with reconnecting, GPS, timeouts, etc. It has reduced a bit, like 20% after the update.

These issues still need to be fixed completely. In most cases, if I change screens and come back to the app, I wait around 10-15 secs to reconnect. If it takes longer, I know it’s not going to, so I end up restarting the game.

Reconnection failing is my biggest complain.
Although, the GPS bug and battle timeouts also are very annoying. Hope Ludia is looking into it


#15

I have gps lock many time
Im on the raod and open game on each city and the map i stock many time to the previous city. Sometime i need 2-3 min to change gps location.


#16

Hey dino hunters, thanks for reporting these issues to us. Turning the location settings off and back on again could help refresh the GPS to your current location. Our FAQ here might be helpful for addition troubleshooting: https://ludia.helpshift.com/a/jurassic-world-alive/?l=en&p=all&s=troubleshooting
Also, an issue with the connection can cause the game to lag or “hang,” and the steps listed on this thread here might be helpful: Stuck on loaded screen of game?
If you’re still having issues, our support team would be happy to assist you. Reach out to them at support+forums@ludia.com with your support key.


#17

After the 240 mb update today the map won’t load anymore, everytjing else works, battle, friendlist, dinodex, but the map just stays blank. And I realyl wanted these 48 Velociraptor attempts


#18

Hi Ned,

The GPS map hang-up appears to be a hung-up process that I think happens randomly as map items like the map, drops and dinosaurs loading as your moving. It’s a hung-up process in the JWA game itself and not do to poor signal.

How do I know this? I also run the MapMyFitness app to keep track of how far I walk and ride my bike and do both while playing JWA. When the JWA map gets hung up and I flip over to the MapMyFitness app, the MapMyFitness is ‘reliably without fail’ showing my exact location. I flip back to JWA and it is still hung up a couple hundred meters back. This proves a problem in the JWA app.

I will try turning the location setting off and on next time I’m out but this is just a work around. There is something causing the “GPS check/map location update” to hang. The other game processes are still alive and working as I can still grab dinos and dart them but it just doesn’t seem to get this hung process to break. I’ve gotten so I just kill and reload the game which is frustrating as all get out because I’m doing this constantly.

If you could pass this issue to your programmers to look into. This is really killing the enjoyment especially when the GPS decides to stick when you see a T-Rex in the distance and your rushing over to get it before it disappears and you find your moving but the game show you stuck back 2-3 hundred meters. Then I start dropping F-bombs instead of darts.


#19

Hi Terminator,
I had freeze-ups right after an update but went away after rebooting my phone so now I reboot my phone after every update.

Some of the issues your having sound much like data connectivity. Did you look at your phone bar strength around the times of those lags when you poke on something and not getting a response?

For the GPS locking. That seems to be a hung process in the programming that I can tell, separate from low signal. I get that issue the most. I hope they will fix it. I think it gets hung during the process of loading map, stops and dinos etiher after darting or while moving (walking, riding or driving), anytime the map reloads. It happens the most while in a car, a bit less on a bike and occasionally while walking even.


#20

Hi Ned,

Me and my wife are just back from a 2 1/2 mile bike ride. We both tried turning the location off and back on but it did not work at all. A hung up process is a hung up process. I counted that I had to reload the game 7 times in the short 2 1/2 miles because the GPS would hang up. There are times the GPS gets stuck and then pops but I can’t rely on that when your looking ahead 2 or 3 blocks to stop and grab the dinosaurs your looking for. It’s really annoying when you go up to the spot for the dino and then have to wait more than a minute to reload the game to do it and then have the GPS stuck in that spot right after or get stuck again in the next hundred or so feet. This happens to both me and my wife. It just happened the GPS was sticking on me more than her.