Ludia Forums

I can't access into my account

Hi there! Here’s the problem: I’ve tried to uninstall and install my game and I cannot access into my account. Since I used Facebook as my main account, I’ve tried many times but the screen is like “frozen” because it kept loading all the time. Please help me!

I’ve tried everything I could, I’m losing the hope now. It has all the progress ever since I downloaded this game from the day it released.

Sounds like you’ll need to get in contact with support about this issue. Contact them via email at support+forums@ludia.com. It will help if you give them your support key in the email.

Though, a few questions:

  1. When did the freezing start? Was it right after an update? I know iOS users recently had a new software update. 13 1.3, I think. If not this, was it after the game’s Arena update?

  2. Is the freezing only occuring when you try to connect your game to Facebook? If this is the case, have you tried logging into FB outside of the game to see if everything is working fine with your login? You can also check your game settings via FB and see if anything is awry with Titan Uprising.

  3. Since there’s nothing more to lose, I would suggest (if you’re Android) going into app info for the game and clearing both app data and app cache before uninstalling. Then try reinstalling. Just to make entirely sure nothing is being left behind.

Still, if none of that does anything, do contact support. Just be aware it might take a few days for them to get back to you. They’ve been clogged with tickets for a while now.

Hope it gets resolved soon!

2 Likes

Hey Tr_n_H_ng_H_nh, as Mysterious had suggested, please do not hesitate to contact our support team so they can try and help you get back into the game ASAP.

@Mysterious

  1. I’m an iOS user so yes, it was after the update. But it was about a bug in the Arena Shop, the time of the items should be re-stock but they didn’t. And I’m using the software 10.0 not 13 1.3.
  2. Yes, and everything is fine with my FB login. And it was okay with Titan Uprising, too.
  3. I had another device, so when I downloaded the game into the other one, it went normal and I played it normally, though it was a little bit glitches.
    And finally, thank you for contacting me, I’m appreciate so much. I will contact to the team ASAP.
    Thank you.
1 Like

If I’m understanding you correctly (and please feel free to correct me if I’m not), you’ve been able to connect your account and get everything up and running with another device since this freeze? Your only problem lies within the other device, the one still harboring the 10.0 iOS update?

If that is the case, then more than likely the problem is with the device itself. Not as in it’s bad or incompatible or anything like that, it just means that there’s probably something going on with it that will need to be figured out. Sounds like something just needs to be flushed. I just don’t know how to go about doing that with iOS when, from the sounds of it, Apple took the ease out of the users hands.

I’m sure support will be able to get you in ASAP, though. At least they’ll do the best they can. I could be wrong and there could be something more going on, but I hope it’s a simple fix. Good luck! :+1:

2 Likes

That’s the one, though I still don’t know why but I’ll figure it out. Thank you for helping me!
I have already sent the e-mail to the support team. I hope that my problem should be fixed soon!

2 Likes