I requested a dinosaur but I can’t collect its dna why

Someone please help I don’t know why it won’t work I’ve tried just about everything btw it’s erlikasourus dna, don’t know if that changes anything

Now my request has completely disappeared

So you didnt get any dna at all, did you check your erlikosaurus page to see if it added?

Yah I got nothin

Because Ludia?

2 Likes

Hey Trainraptorz, could you send an email to our support team at support+forums@ludia.com with your support key so our team can take a closer look at this for you?

If you could include the approximate date/time of when you had tried to collect your DNA request as well, it’d really help our team out.

Thank you!

1 Like

Out of curiosity, what rule was not followed?

1 Like

i agree why?

1 Like

For those that are saying I broke a rule, I didn’t and if I did I was an accident. Seriously I know the rules why would I risk getting kicked, the rules are no rare request on weekends, no putting dinos in lvl 20 sact, and do my 10 takedowns for tournament and I haven’t broke a single one for the past 4 months I’ve been in the alliance

Ps I reported not because I was mad because he is kinda rude and said some mean things to me and other members

Also this problem was a week ago

So there weren’t any broken rules?

There where not

If anyone wants to send me ingame request my last four digits is 8741