Ludia Forums

Incompatibility

#1

My Nokia 2.1 is not compatible with the application, changing the phone recently, I am a VIP user, what can I do !!!

#2

Take the phone back… or wait and pray Ludia decides to add android go support if there even able.

#3

I’m sorry to hear that your current device is not compatible with the game, @Gamalier_Chamblat. Sadly, there wouldn’t be much our team can really do at the moment since this is a device related issue. If possible we recommend playing the game on another compatible device, our FAQ here has more information on the minimum requirements for Android devices: https://ludia.helpshift.com/a/jurassic-world-alive/?s=device-compatibility&f=android-what-devices-are-compatible&p=all
I hope this helps!