Incubator free speed up


#1

For the past few days mine free incubator speed up is not working, normally if the incubator is under 15 mins, it will ask if I want to watch an ad to speed up the 15 mins.

But this is not happening any more, I had tried force close the app but still the same.

Just asking if this benefit is no longer available? Or there is something I can do to have it back?


#2

It’s available with me… Contact Ludia support, they can probably help…


#3

It works for me.


#4

Hey night, the video speed-up is usually not available when you first activate a 15 min Incubator, you’ll need to wait for the timer to tick down a bit before the option appears. However, if the option doesn’t appear at all for you, email our support team at support+forums@ludia.com with your support key, and they’ll be happy to take a closer look at your account.


#5

Try to open the incubator page where it says the cash amount to open it. While that page is open try and force close and reopen the app


#6

Do you use any ad blocking software that might interfere?