Ludia Forums

Indominus Rex Bug


#1

Currently with this newest update (1.3.11), when the Indominus Rex uses cloak, the 2x damage doesn’t activate. Indominus rex still just does regular damage with whatever ability it used without getting the 2x damage buff from cloak.


Indominus Rex Cloaking Damage Bug
Does anyone indom’s cloak doesn’t work properly?
Problem with I rex
#2

Same idk why but happens to me as well.


#3

Please fix this. Tested multiple times with friendly challenge as well. Indominus Rex is absolutely useless when one of its key abilities is not working! :scream:


#4

I would assume if this is broken on Indominus Rex, it’s probably broken on Erlidominus too.


#5

I can also confirm this bug.


#6

It is not universal. Just had a level 17 Indom stealth hit me for 3000 and it was not a crit. I assumed they fixed the bug but then a moment later my Indom only hit for 1700.

A side note. TRex is now trash. No health increase and very slow so now he didn’t do enough to kill and anything faster than him kills him with their second attack.


#7

Ok, I’m not crazy. My indominus is behaving the same. I thought it was armor piercing not working.


#8

Same problem i think for sometimes dont use indominus i wasted so much to crated indominus but now its useless


#9

They did a good job on nerfing Indominus (well, there was this Hybrid Rarity thing … he is created by fusing Epic Rex and Common V-Raptor … so he’s not as good as other Hybrids). :rofl:


#10

Yea, mine is not doubling its damage either after cloak. Please fix.


#11

Yeah I’m getting same is sure, I only have it at 16, but it only does 1400, it us3d to do like 4000, Ludia plz fix this bug, it’s making all my hard work go to waste.


#12

Mins is working sometimes then not working other times


#13

Hey everyone, thanks for reporting this issue to us. Reach out to our support team here at support+forums@ludia.com with your support key and more information on this so they can investigate further. Including any screenshot you have on this issue in your email will also be really helpful.


#14

I just got an indom today and I tried to use cloak for double damage at least in 5 battles but it just a 50% dodge move, it doesn’t give me the double damage(it does says that it is going to do double damage when I hold the rampage move but the damage output isn’t double)


#15

I can confirm this as well as I have tested and witnessed it in the arena multiple times today. Also sent in support email already as well about it.


#16

Same here. Dont even want to use him right now


#17

Since the new update, my indominus no longer does 4x damage with cloak plus armor piercing rampage.


#18

I tried using the basic strike with a cloak as well. Just the normal 1x damage.


#19

When i use cloack and after that i use armor piercing rampage it should do 4 Times damage beacuse when You use cloack it does 2 Times damage and rampage = 4X dmg But it doesnt, now it only does 2X dmg. it was working perfectly fine before The update.


#20