Ludia Forums


Dear Ludia,

after months of collecting velociraptor DNA, I can finally create the Indoraptor. Now, every time I want to get it out of the creation lab, the game crashes…

Is there something I/you can do?

I’m sorry to hear that is happening with your game @Thomas_Peeters, could you try shutting down and rebooting your device and see if that helps? If you’re still having this crashing issue after restarting your device, please contact our support team here at with your support key so our team can assist you further.

Dear Ned,

the problem is still standing after rebooting my device.

Can you help me?


I’m sorry to hear that the crashing is still happening, our team has been notified of the issue, and a fix for it should be coming out soon. When the Community Fusion event is finished and if you had participated, claim the prize to dismiss the event from your event list and then try taking out your Indoraptor again and see if it works. If you’re still having issues, could you contact our support team with your support key?

Dear Ned,

where can I find my support key?


Your support key should be displayed at the bottom of the loading screen when you first launch the game. It can also be found in the Options Menus by tapping on the “gear” icon on the upper left corner in the game.

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: game crashes when trying to collect newly discovered superhybrids from creation lab

Area is was found in: creation lab

How do you reproduce the bug:
Step 1- fuse indominus rex with SDNA
step 2 - collect indoraptor after completion
(add more if needed)

How often does it happen: everytime i try to collect the dinosaur

What type of device are you using:
Anything else? (add screenshots or additional information here)

You should post this in the jurassic world the game forum and not jurassic world alive forum.

we have move this to the Jurassic World: The Game section

Same problem. Got latest update today which fixed the problem with events but when I try to collect my indoraptor from the creation lab the game crashes.

I need help with this also. It’s super frustrating. I hope I don’t lose my indoraptor.

I seriously need help collecting my indoraptor it freezes and kicks me out every time I tried collecting it this is ridiculous!

Any updates support? Still can’t collect my indoraptor.

They contacted me to say when the community event is over, it would be ok. It’s not though! Still keeps freezing!!

I’m sorry to hear that you’re still having issues after the Community Fusion event was over @Sam_Gillson. If you had participated in the event, could you make sure that you claim the prize to dismiss the event from your event list and see if that fixes the freezing? If you’re still having issues, email our support team here at with your support key so our team can investigate further.

I claimed my prizes and it is cleared from my events but I still cannnot collect my indoraptor. I emailed support.

Whatever you do, don’t remove the app and reinstall because of this issue…lol…I did that on my iPhone XS and it reset the app to the beginning even logging on with the FB account…I logged a ticket with support and after providing old and new support key and account ID and it’s still not done…frustrating is an understatement!!! Luckily the app on my iPad Pro is still in tact and still running normally but still with this superhybrid fusion issue.

I am trying to evolve into indoraptor and it says complete button but the. When I press it, crashes the app

Does anyone know what date it will be fixed? Because it’s really annoying.

Your support sucks. When are we going to get a response?