IndoT cloak bug

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: IndoT cloak does not display proper cloaking effects. Only shows dodge ‘hexagons’ at the beginning of animation and then nothing, as if it was not cloaked.

Area is was found in: arena

How do you reproduce the bug:
Step 1- use indotaurus cloak
Step 2 - boom, no invisibility
(add more if needed)

How often does it happen: always

What type of device are you using: iPhone 11

Anything else? (add screenshots or additional information here)
Been going on since release, and I thought it would be fixed, but it hasn’t


For some reason, it doesn’t have that normally. It isn’t a glitch, just the way they created it. It should have the cloak, but it doesn’t.

Yeah, it seems like it was intended, but why? It would actually look pretty cool if it had the invis effect

1 Like

Thanks for reporting this to us, Freezehydra! Indotaurus’s Cloak is being investigated by our team. The issue should only be visual, however, and the effects of Cloak are still active.

1 Like

Yeah, the effects of cloak (dmg and dodge) do work, it’s just the visual portion

1 Like

I honestly don’t mind this bug, at least the effects still function normally!

Plus out of all the bugs that this game has had over the years, this glitch is pretty minor and the tamest one by far.

Sure it’s inconvenient, but at least it doesn’t break the game.

3 Likes

Thats why u should check dini stats again and again haha :joy: