Ludia Forums

Invincible dragon glitch/why can't I post pictures here anymore

#1

Alright so this has been a glitch that’s been here since the begining of the game. I thought it had been resolved but apparently not so because it happened again not to long ago. So basically what happens is that after defeating a dragon, instead of its fading away animation it just stays there. It does nothing, you can’t kill it. It just stays there and counts like a dragon. Multiple times during the begining of the game did I have to wait or log out of the game because of these guys just staying behind and keeping me from finishing the stage. Please look into this as it is midley irritating. Pics not posting. I’ll do it when I can

#2

I don’t seem to be able to post the pictures I am not sure why. It says I have low memory but I checked my settings and I still have a chunck of it left. Anyone else having this problem with the forums?

#3

That sucks… I hope they do something about it, but something tells me it won’t be soon enough. I’ve been complaining for several issues as well, and there doesn’t seem to be any real response.

#4

What do you mean, there’s forum memory too? If we post too much we won’t be able to post again?

Or are you talking about your phone memory?

Sorry, but I did not get that part.

#5

Thanks for letting us know, @Swoop. If you remember the date and time of when this happened, could you contact our support team here at support+forums@ludia.com with your support key so they can investigate?