Ludia Forums

Is anyone else having this issue? Can’t log in

Hasn’t let me in for about an hour and a half, on wifi or cellular data. Any insight?

1 Like

Try restarting your phone

Tried that already, didn’t work. Also tried reinstalling, didn’t work either.

same i just made a post regarding this issue, i hope its resolved by tomorrow. i need that antarctovenator. if anyone cant get on to try and dart it i sure hope ludia can make up for it.

Happens once in a blue moon, nothing you can do about it other than wait it out. Extremely annoying, really makes you reconsider your life choices.

Yeah, thats true. but ive been eagerly waiting to get to dart antartovenator, its the first unique id be able to unlock. plus all progress ive made in the game has been without buying anything with real money and being able to unlock it was gonna be a huge milestone for me.

1 Like

I hope it resolves itself quickly :crossed_fingers:

Me too, ive just tried uninstalling and reinstalling it but still nothing

Hey @DinoMaster3000, and @Keagan_Klinger, if you haven’t already, please contact our support team here at support+forums@ludia.com so our team can assist you further.

Thank you!

Ok, i sent an email now. i just hope I can get help.