JWA Game map serious performance issues after 2.15 update

Same here. It sucks

I have had issues with lagging and the game literally shutting off numerous times while I’m playing for the last two updates. I’m lucky to play for a half hour before the app just shuts off and I have to reload it. Hopefully a solution is found before more creatures are discovered or updated. I would much rather be able to play the game.

2 Likes

Hi @MrDinoMan, your frustration is completely understandable. As Ned stated, we still do not have an ETA on the matter. The team is working on it and everyone will be updated as soon as we get more information. :t_rex:

3 Likes

Thank you @Breona & @Ned !!! I really appreciate the updates on this. Can you pass along one suggestion to the developers to help find the cause? - - - Add a selectable filter to the game of things that get rendered (and/or are selectable) on the map. (i.e. spawns, sanctuaries, bosses, drops, strike towers) Turn them all off with the filter and observe map performance. Then unfilter each individual feature separately and see if one affects performance more than another. Btw, I would love such a filter while playing as well, I hate when the game accidentally registers a click on a sanctuary

2 Likes

This morning I literally cannot get my game to load, for the time being it won’t get past 8.

Also trying to raid with these issues is an absolute nightmare, almost every single raid turns into a powerpoint presentation and it becomes impossible.

3 Likes

Good morning @MrDinoMan! Thank you for the appreciation and I will pass this suggestion on to the team! :mega:

1 Like

Same problem on an iPhone 11, too. It’s very annoying on long car rides, where it causes me to miss valuable dinos. It doesn’t seem to happen to my friend, though. I really hope they fix this soon.

I have a Galaxy S20 and I just traveled 700 miles round trip to visit family. I didn’t have a huge problem but the issue I see that causes so much lag is just the amount of things that devices have to display as the driver is driving 80mph on the freeway. Driving through farmland isn’t too bad but when I would get into a congested city with residential housing and businesses on both sides, the lag gets so bad, it just about gets unplayable.

It would really be nice if we had the option to turn certain things on and off from displaying such as sanctuaries, raid bosses, drops and creatures. Yes, so that we literally could have a blank map with just roads or just roads and creatures if we are just interested in looking for good things to dart. Even just drops, if we are just working to max our coins.

Even just turning raid bosses off so we can spin drops and grab towers and chests when certain raid bosses are on the spot such as Postimetrodon, pokey Bajadasaurus and Meiolania. You guy refuse to fix these raid creature hit boxes so give us the option to turn them off from displaying.

My issue is it takes forever to go into the creature screen with my team and just opening a creature is just taking forever to load now.

3 Likes

This update lags the map and sometimes battles so bad…

Sometimes it wont even show anything on the map but I’ve found a fix, click on a scent and close it and the map is back to nornal. The wprst thing - doing it 100 billion times :tired_face:

2 Likes

That’s a nice suggestion.
On top of that, they can also show the ‘local area’ they’re in.

1 Like

Why does this lag STILL exist.

4 Likes

Same. Clicking on a dino in my dex takes forever.

I’ve found if you tag the ones you’re most interested in from your inventory then choose only those tags so there only a few dinos shown then clicking on a dino is much quicker.

So the huge delay with full list must have something to do with the way they remove / deallocate the dinos that are shown on screen.

Ludia - performance would be immediately improved if not all dinos were automatically shown at once in the inventory. Give us folders or some other way to organize them. 1/2 of my 300+ dinos, I never ever look at and don’t need them readily shown on my inventory

1 Like

I can’t play on my iPhone 6 anymore! Or has only 1 GB RAM! That’s not enough to play. At least by me is that so.
So I had to use a phone with at least 2 GB RAM, an iPhone SE (1. Gen 2016), so that I can play again.
But still… It was only working until update 2.15 came out. Now the lag make the game nearly unplayable!

2 Likes

The performance is so horrible I can not play at all. Grpahic is jerky, darting impossible. Even during battle the reponse is so slow fighting is impossibe.
Samsung Galaxy A7 tablet …
I give up JWA if this will not change soon …

2 Likes

@Breona, @Ned, any update please? Why is the team not posting a daily update on the status as the game has pretty much become unplayable in all these areas:

  • Map (as posted above),
  • Raids (crashes all the time while trying to set or invite alliance to raid, today we all had to give up after almost an hour of trying),
  • PvPs (I cannot now even select my 1st dino as the game timer runs out and auto-selects),
  • Any time going between screens

So many more areas, surely the development team can’t be that clueless on what they have done in the 2.15 update code that went out untested?

Is it external tech that you use that has been updated without your knowledge? Google Maps, TapJoy ad system or even Unity update that the game engine runs on and the team forgot to beta test before compiling with 2.15?

I have players in my alliance who have been paying for the game as VIP from start and are now cancelling their subscription because of the game becoming unplayable.

This will kill the game player base completely and all the Ludia managing director (via you or directly) need to do is keep everyone updated daily on the progress and if they are big enough at heart then throwing in a humble apology for the lack of update and poor communication. Can’t be that difficult right? :man_shrugging:

4 Likes

Continuing the discussion from JWA Game map serious performance issues after 2.15 update:

Months and months and this lag is STILL horrendous. This is absolutely uncalled for from a company that all but begs us to spend real money on fake stuff. Turning on maps in the background doesn’t even work anymore. STOP SPENDING REAL MONEY UNTIL THEY FIX THIS AND EVERYTHING ELSE WE HAVE BEEN SAYING!!! Then they will either fix the issues or close the game for good.

1 Like

I’d like to know this as well…

3 Likes

I thought it was just me. Good to know im not the only one experiencing this horrible lag on the map

2 Likes

One can only think it must only be happening on less than optimum devices for the game to run as it should.

A cynic may suggest that JamCity/Ludia figure anyone playing on an inferior device probably won’t have much spare cash to spend on the game….

I hope that’s not the case but I can’t help wondering.

I doubt it mostly because there’s posts in this thread saying they have newer devices and they’re getting the lag. Also because this horrid lag wasn’t present prior.

2 Likes