Mortem rex bugg

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description:
Made a purchase for grand premium pass. Received bunch of nice stuff and Mortem rex Dna.
Area is was found in:

How do you reproduce the bug:
Step 1- after receiving Dna i tried to create creature and i had 300/300 dna but it says not enough
Step 2 - but now i got only 150 dna and cant create mortem rex anymore
(add more if needed)

How often does it happen:

What type of device are you using:using note 20+

Anything else? (add screenshots or additional information here)

@Constappable hope you tried a restart (maybe its only a Temp Issue)

If you still face the Problem, you have to reach out to the Support, no one can help you here with a Solution to your Problem.

support+forums@ludia.com or
https://ludia.helpshift.com/hc/en/21-jurassic-world-alive/contact-us/

I did restart 3 times, after 3rd try it went down to 150 dna and i cannot create anything now.

Hey @Constappable, as sp0nge said, you will need to write to support+alive@ludia.com so we can look into this for you. Please provide your support key as well.

Thank you!

Hi. I have sent messages about it to ludia support. Waiting for answer.

1 Like