New campaign bug

E.g. Campaign 4.1 intermediate mode:

Requiring common create at level 15 but the match caps everything at 14??

1 Like

I found out it’s doable, tricky but still doable. Btw I have a level 15 Dimo.
So the key is to use only regular attack (without dot as we already figured out it doesn’t count), and if you eliminate 2 first creatures with any other creature and keep dimo to handle the last 2 creatures It’s even easier than you think. Because those last 2 will keep swapping and healing while your dimo keeps on attacking them. This will get you about 3000 damage.

Try to have fun:)

Processing: 8B53407A-3D54-4FEE-9632-088417C0D977.jpeg…

1 Like

Yeah I tried doing exactly that a few days ago, and it worked. Waiting until the last two dinos really does help a lot! I’m still not sure how doable it is with a level 10 or lower Dimorphodon though.

1 Like

That in reality is win with edaphosaurus alone because you can only use one creature so… in other words it’s impossible unless you are crazy like me and did something like that

(Megalogaia is lvl 26)

Before you decide to skip reading, no. This is not a complaint where I rant about something being too hard to complete.
I have found something that, functionally, IS impossible.

So, I’m going through the campaign to complete every reward and I notice that I cannot complete an Intermediate version of a stage. The stage is Course 4, Level 1. The condition is to complete the stage with a common that is at least level 15.


But as you can see, the roster within is capped at level 14.

Is this intentional? I have experienced quite a few glitches during my battles in the campaign, but this cannot be right.
Does anyone have an explanation?

2 Likes

Have you been able to do that one? (Beat 3 taking less than 1000 damage?). I’m struggling with it right now :face_with_symbols_over_mouth:

Nope only way I can think of is to do is with repetitive dodge moves but not sure I have dinos sufficiently strong to do it.

Campaign mode, intermediate level. Course 2: fierce. 1st battle. Special objective is to win with a cunning in your team. Won using said cunning (not just carrying it). Result didn’t recognise I’d used a cunning, so won’t record me as completing the special objective and thus the round.

I got confused with one like that. It wants just one creature on your team not just one fierce in the team.

1 Like

There are two slots. I picked allo gen 2 (f) & arg (c). Beat it with the cunning. Just having it in the team fulfills the requirement but when that didn’t work I won with the cunning.

I have found this too. Some work and some don’t.

My example was “Have t rex on your team”. I did and it didn’t register

1 Like

So that’s the new campaign mode not working then?


Does anyone know how to do this I tried having 3 different cloak dinos and did the cloak three times but nothing happens then I tried just one dino doing three different cloaks and still nothing only thing I didn’t try was using legendary irex

1 Like

Are there any fixes forthcoming to all these issues regarding Campaigns? They seem to be of two types: One isn’t really a bug, just a usability problem with poor explanatory text. You’d think that would be relatively easy to fix since it’s “cosmetic”. The other appears to be genuine bugs and can be extremely frustrating. I’ve been running into issues regularly where I followed the instructions and it still wasn’t recognized.

Hey Johnb, please rest assured that our team is still actively looking into the reported Campaign 2.0 Special Objective issues.

More information and updates can be found here:

1 Like

Thanks very much for the quick response!

1 Like

Bug Description: The special objective states I have to use a Level 15 or above common creature, yet all of the creatures are capped at Level 14.

Area is was found in: Campaign Course 4 Armour 1 Intermediate

How often does it happen: Everytime I attempt the campaign.

What type of device are you using? Iphone

My current fav is Course 4 (Armor Piercing) #3 beginner where the goal is to “Swap Koolasuchus G2 for Velociraptor” even though NEITHER of them qualify because they don’t have armor piercing effects. :crazy_face:

I was also stuck on this - but found the hint earlier in this thread.

The first dino you select - no you can’t select those dinos.

But you can for the 2nd and 3rd dino!

I’ve been trying to get a few of these missions done and it’s not letting me. The first picture is showing what my creatures look like normally second picture is the mission the third picture is what they are allowing me to choose nothing above a 14. And it’s not just me because my alliance is having the same issue. It only that you have one dinosaur in your team so that tells me I’m not breaking that role why aren’t they above or at 15 or higher in order to be able to complete that mission.