Ludia Forums

New Version of Game Won't Install

When I go to the game, it tells me to go to the store.

At the store, the only options are to play or uninstall.

After several uninstall / reinstall attempts, no joy.
The cycle repeats.

Using a Samsung Android if that helps.

Any ideas greatly appreciated.

Yeah. I saw it as well, so I had to wait

There’s a new update now

Same issue here what do I do?

Seems to have fixed itself.

I tried again, and it just worked.

Same issue here. Uninstalled, installed again and the game won’t open. Keeps saying I need to update.

I still can’t get in.

Found a way. I am using Android, so I went to the Google App Store, searched the full name of the game and there was an option to update. It worked, but logged automatically on the game with my google account after forcing me to install Google Games or something like that. My original account with the game was linked to my Facebook profile, so essencially the game started a new account for me. And it’s driving me crazy with an absurd begginer tutorial that I can’t just skip to switch accounts. Who the hell tought it would be a good ideia to make a unskippable tutorial in the game?

1 Like

Had the same problem, this works. Thanks.

If go to my app & management, and go to update u will see the game update pending :3
Good luck

AKA: update manually

I couldn’t get the new version to show on my wifes phone either.
I had to toggle from wifi to cell and that somehow fixed it.