Ludia Forums

[News] Jurassic World Alive | Alliance Missions Issue - Update


#21

Did you even read the OP before posting in this topic?


#23

You get the rewards for the highest rank achieved, not rewards for each rank.


#24

Yeah that’s why the incubators are upgraded, you don’t get one for each tier.


#25

Or are you asking about the exploration reward? That will get sent out later.


#26

No
Just read it now
Was in jw playing and didn’t see the post regarding the disabling if the missions
My mistake sorry


#27

Just got this one

Gunna patiently wait for its partner to show up


#29

Its saying the misson is over already.


#30

You guys do realize that you sent us the useless incubator prize. I would’ve much rather had the sinoceratops, einosuchus, and triceratops gen 2 DNA! Those actually make good hybrids! My alliance worked their butts off for nothing. I hope this gets fixed, and you send us the other half of the prizes from last week. Thank you


#31

I assume they are still working on it, none if it’s got the good reward yet


#32

I haven’t gotten a single alliance reward… And my alliance made it to rank 4 and 3


#33

It’s in the notifications area, you have to click on the notification to get it.


#34

Any idea when the the missions will start up again? Like tonight or tomorrow or longer then that?

And I assume that due to this bug the challenge “week” will no longer start or end on a Monday from this point on?


#35

I only received the Defense incubator as well. The incubator I really wanted, the Exploration incubator, was nowhere to be found. I’m extremely disappointed. How could they not know that is the one we all actually wanted and at least be sure to give us that one first? It’s weird how they don’t seem to know useful dinos from useless dinos.


#36

Some of these comments… :man_facepalming:


#37

We are being given the wrong incubator for the exploration rank. We achieved rank 4 minutes before the crash in your system. So, we should receive tier 5 rewards as compensation (as for your announcement). However we only received the rank 4 (the tier we got rather than tier+1).

Here is proof of our rank 4 achievement @Jorge . Just because none of us upgraded the image before it crashed doesn’t mean we didn’t achieve it.

This is our alliance and my #ID

I hope that you can fix this issue and compensate us with the right rewards. Thanks.

I’m still waiting on feedback about this issue, @Ned or someone?


Issue with alliance mission incubators
#38

Just received my level 5 Explore incubator…yea…thanks Ludia!!! :slight_smile:


#39

Are the missions counting while disabled? I guess not, right?


#40

Thanks for letting us know. Probably the best choice until it is ready to go.

I did get my second Incubator email which managed to crash the app when I tried to open it. Hoping I will still get the contents somehow?


#41

And yep, the missed rewards showed up when I reopened the app - all good. Thanks!


#42

The missions are NOT updating. I still have them showing on my Ipad still logged in from this morning when I got home and direct hits and seeking supplies are not updating when I do them.