No Battle Incubator Drop


#1

I just won an arena battle to fill my incubator slots and despite only having 3, the “all slots full” notice popped up at the end of the battle and I got no incubator. Particularly frustrating since I’ve been on a steady losing streak and it took me about ten battles to get the one incubator…


Battles - all slots are full
#2

Hey Unicornodon, try rebooting your game or device and see if the Incubator shows up, if you’re still having issues, reach out to our support team at support+forums@ludia.com with your support key so they can take a look at your account.


#3

Did a game reboot, jumped around between the tabs, and the incubator did indeed appear!


#4

Anyone else had this happpen?

Just won a battle in Jurassic ruins (got in there for the first time yesterday and imagine I will go up and down for a while until I increase my dinos power further and get a few more epics). When I won I didn’t get an incubator as it said all my slots are full…

Except they aren’t all full I have one free space still left.

Missed out on one incubators worth of rewards and one further slot away from a 24 hour incubator.

Hardly third world problems but annoying none the less and was interested if others have seen this happen?


#5

I have had this happen once but it turned out to be a visual glitch. There actually was an incubator there. I just couldn’t see it at the time.


#6

Lol, it told me all slots were full and showed no incubator but after your post I signed back in and an incubator is there. Never seen that before.

Thanks