Ludia Forums

"not compatible with your device"(Using an android)


#1

So, my android(which is past version 4.4) is supposedly not able to run the game, i’ve tried two androids infact, a lenova tab and a zte L5, both supposedly incompatible, anyone able to help?..