Nothing will load on the map. PLEASE HELP!

I was without my game for over a month, two weeks ago support finally helped me get it back, now nothing will load on the maps :cry:
I can battle, I can update creatures, I can do anything in the app except my map is empty.
I tried to fix this problem by…

  1. I restarted the game at least 20 times
  2. Checked to be sure there were no updates for my phone, Jurassic world alive, or google maps
  3. Checked my WiFi connection
  4. Tried a different WiFi connection
    Please do t take six weeks to help me again!!! I am a VIP member image

Hey there, @Remi, I’m sorry to hear that you’re not seeing anything spawn on the map! I’m not sure what might be causing this to happen but our support team would be glad to take a closer look and try to provide you with additional troubleshooting steps! Reach out to them at support+forums@ludia.com, including your support key in the email so that they can locate your account more quickly.

It’s crazy because last time it took six weeks! I did send my info to support, but got back a generic email saying they are getting lots of problems & mine would be addressed as soon as they could get to it.
Hey problem is once they write me back with a question & I write back with my answer, I have to wait days again for another reply

I’m really sorry to hear that you had to wait for such a long time to get a reply! If this issue occurs again, maybe some of the troubleshooting steps listed here could be of use:

1 Like

Same issue here. Have sent both email/in game msg. I was supposed to hunt smilodon and I DON’T want to miss 3 boost towers…

Reinstalling just worked for me…

1 Like