Ludia Forums

OFFICIAL, my dracoceratops DONT WORK

#1

my previous post, which i had many many replies on about how i think the (insert words here) at ludia should remove the dracotops is gone, and not going into what was said just hope some of you may recall the post , but anyway, i now have my Dracoceratops, and you know what? IT DON’T WORK!! on swap in, it just stands there, does nothing, i choose an attack to do, it does the attack, but i still cant swap for 2 turns and the other guy kills me…well ok, this is all fine and dandy BUT either ludia is messing with me on purpose or im just having really, REALLY bad luck on this pos game because EVERYONE ELSE’S draco works on swap in, insta kills me and such, and im not kidding, not exaggerating, MINE DON’T WORK ON SWAP IN…again, the opponents does tho, hmmmmmmm…so is ludia messing with me or what? and the same goes for my indominus rex, the “priority” dodge/cloak NEVER takes effect and if im lucky enough to get at least 1 hit in befoer it gets killed, i guess that’s good…so what the (insert words here) is going on??? yea, i fussed about the draco before and im still ALL FOR NERFING it, but since i now have mine, it don’t work anyway so why’s that? someone friend me, airwolf, come see for yourself, that is if im lucky enough to get it on the random draw for the fight.,…,.

#2

Take a chill pill and relax.

When you say Dracoceratops does nothing, you mean when it swaps in it doesn’t attack?

When you say Indominus priority cloak never takes effect you mean it doesn’t happen or the cloak fails more often than works?

It’s not quite clear whether things aren’t working as they should or you’re just frustrated because of the RNG going against you.

Try taking some recordings to show us what the issue is.

1 Like
#3

yes, im saying on swap in, draco DONT attack, just stands there, but everyone else’s does tho except mine. and as for the indo, cloak does apply, but i sill take damage and if i don’t get a turn after the first hit, im dead…so yes, the cloak on indo 99.9 percent dont work for me and now, to be repetitive, the draco 100 perc dont work on swap in.

#4

image

4 Likes
#5

Well I don’t believe the Draco does nothing on swap-in. Your complaint about cloak is just moaning about RNG and probably exaggerating the 99.9%.

I’d be very interested to see a recording of Dracoceratops doing nothing in swap-in.

#6

ok ill do the recording, dont really know how but ill figure it out…stand by

#7

ok i dont see any kind of record option within the game…how do i do it?

#8

You use the record option on your phone.

1 Like
#9

I can’t add you as a friend as I don’t know your # tag.

1 Like
#10

name airwolf, dunno what my tag is either, unless its that number after my name? if so its 8177

2 Likes
#11

Go in game and tap on your level in top left corner you will see your name and # tag.

1 Like
#12

Yeah, i’ll add you.

1 Like
#13

im on now…

1 Like
#14

I’ve added you.

1 Like
#15

un believeable

1 Like
#16

didnt get draco on 2nd battle

1 Like
#17

So for those reading this, this is how it went.

I brought out Allosino he brought out Indom.
He cloaked straight away and cloak worked.
I used priority attack, his cloak worked.

I then swapped in Dracoceratops at same time he swapped in Dracoceratops, ypu that’s right, his Dracoceratops worked.

We then did a second fight…

He brought out Indom… yup that’s right his cloak worked on first hit.

We did third fight, he brought out Indom again. Cloak failed first hit, worked second hit.

1 Like
#18

ok there ya go…lol told ya

1 Like
#19

LMAO that’s not a swap-in!

I killed your Indominus, you picked Dracoceratops as your next dino. The attack is only when you chose to swap-in Draco to swap-out your current dino.

Dude, I don’t know how you have Indoraptor without knowing what Swap-in moves are by now.

4 Likes
#20

next time, if my draco survives, dont kill it…let me swap out then back in…it didnt work 2nd fight