Quetzorion Long Shield not working while cloaked

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: Received damage while long invincibility ON

Area is was found in:
Battling in Arena 11
How do you reproduce the bug:
Step 1- only happened once.
Step 2 - My quetzorion vs erlidominus.

Erlidominus cloaked.

Quetzorion activates Long shield

then I use cloak movement (don’t know how is this in English).

Erlidominus uses rampage. I receive 33% of damage as if long shield was not ON.

How often does it happen: only once.

What type of device are you using: Xiaomi Mi9 se Android.

Anything else? (add screenshots or additional information here)

So you’re saying you had a shield AND cloak and you received damage? Interesting bug!

Quetzorion doesn’t have cloak. He used sidestep

Thanks for reporting this to us, @Pirulass. Could you send your support key over to our team here at support+forums@ludia.com so our team can take a closer look at this? Thanks!

Yes. Maybe Long shield animation kept running one extra turn. Don’t know.

Ah, that seems more likely. Didn’t realize that bug is still there :slight_smile: That’s an old one!

Yeah I noticed that too!

1 Like

Already Sent mail to support. Lets see What Is happening here


Here I reproduced the bug with a friend in friendly battle
1 Like

Had this happen to me tonight, was also against Erlidom and I had Invincibility up and his cloaked attack still caused damage despite shield being up and still had another hit to take on it.

1 Like