Recruit A Friend glitchy

Glitchy or completely non-functional??

This needs to be disabled again and communicated asap.

3 Likes

I tried to recruit a friend and even tried to be a recruit for someone and every time I get an error message.

Am I doing something wrong or is it bugged. Send me screenshots of you having proof of either it works or it doesn’t

3 Likes

You can’t be a recruit for someone. Only new players can be recruits, not someone already level 13.

Here’s your proof it works.

Same issues on mine as well

1 Like

I sent out 2 links yesterday and then had this waiting this morning


Brand new player brand new account and neither link would work.

2 Likes

We have a few that have worked successfully now too. It seems the key is for both players to restart their devices many times and pray.

It would be nice if Ludia actually communicated how the process was supposed to work as it’s clear unrecoverable errors can occur at multiple points.

With my first recruit, I sent him a friend request to see if it would help link our accounts and I don’t know if that screwed up the process somehow. I understand there’s supposed to be an automated request sent from him to me, which seems to only happen after he restarts his device? Regardless, it’s very confusing and better documentation is sorely needed.

Yeeep once again ludia crushing it with the communication

1 Like

I tried recruiting a friend. She has never played before or installed the app. Sent her the link and she did everything she was supposed to and I got the error in my in game inbox. All it did was send me a friend request in game from her account. It didn’t register as a recruit. I tried contacting support TWICE asking what to do because now she’s already made an account and started playing. The recruit link supposedly only works if you’ve never installed the game. And the answer from support was just instructions on how to recruit a friend… Both times. They didn’t answer my question about what to do. I even asked specifically if she should stop playing or if they needed her support code too. Can she never be my recruit now since it didn’t register??? I’m so confused and actually a bit angry with support for bad customer service…

2 Likes

If they told you this then they lied. The friend has to have the app installed first, just not opened it. It clearly does have issues they need to fix.

This can’t be true… In the original post Ludia said you could recruit someone under level 5 or who hadn’t played the game for 3+ months. So surely they would’ve already downloaded the game.

Obviously it isn’t true because of things mentioned here, but that’s what ludia support told me in their emails TWICE. But they gave no solution to my issue :upside_down_face: So I’m still wondering what we’re supposed to do. Does she need to stop playing for 90 days before we try again? That doesn’t sound like a very good solution…

1 Like

No they said Under level 5 AND hadn’t played for 3 months. Not OR.
If they are under level 5 and have played in the last 3 months it won’t work.

1 Like

This is what I meant, thanks for correcting.

Hey DPG members, our FAQ here has some updated info on the Recruit A Friend feature:

1 Like

Thanks @Ned, I think that should explain all the problems people have been having. :+1:

1 Like

No… It does not give me an answer. Because my friend was eligible… She had never installed the game. She followed the link from me and did everything right… But it just didn’t register :woman_shrugging: I got an error in my inbox plus a friend request automatically sent from her newly created account to mine.

And how did you give the link to your friend exactly?

Explain step by step how you actually provided them the link.

I opened my game went to the recruit tab and clicked recruit and chose send via Facebook messenger.

Having a lot of problems with this aswell. Girlfriend has a level 3. Started about a week or 2 ago. I send her a recruit link via Discord and when she opens the app there is a “Collect” on the alliance recruitment in the bottom right. Tap it and nothing shows up just the usual “search for alliance”.

I’m already friends with her profile and she played campaign up to the point you can start playing PVP.

Meanwhile all i get on mine is the “token is invalid” message. This whole thing seems broken.